Issues with media and document downloads and uploads
Incident Report for CorpU
Resolved
The media issues have been resolved and our service is operating normally. We will continue to monitor the situation.
Posted Mar 20, 2018 - 17:00 UTC
Monitoring
An issue with our upstream provider is causing intermittent issues with slow downloads and uploads of media and documents. This includes site style elements, profile pictures, document downloads, and in some cases video streaming and uploads.

We are monitoring the situation and will report as we get updates from our upstream provider.
Posted Mar 20, 2018 - 15:47 UTC