Email issues related to delivery and bad request links on emails already sent
Incident Report for CorpU
Resolved
This incident has been resolved. We will continue to monitor for the rest of the day.
Posted Jun 15, 2020 - 17:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2020 - 15:39 UTC
Investigating
We are currently investigating this issue.
Posted Jun 15, 2020 - 13:42 UTC