The Incident related to Dashboards and Reports has been resolved. All data is processing as expected at this time. We apologize for any inconvenience this disruption may have caused.
Posted May 22, 2024 - 14:54 UTC
Monitoring
A fix for the Dashboards and Reports has been implemented, and we are continuing to monitor the results.
Posted May 20, 2024 - 17:53 UTC
Update
We have identified the issue with the Dashboards and Reports, and are continuing to recover the data. We will provide an update once the data has been fully restored.
Posted May 17, 2024 - 23:38 UTC
Identified
An issue has been identified with failing infrastructure related to dashboards and reporting. We are working on restoring the data feeds for these reports, and will provide additional updates once available. We apologize for any inconvenience this may have caused.