Moderate to long delay on first access to site
Incident Report for CorpU
Resolved
Our engineers have made a tweak that has resolved performance issues on the site. We will continue to monitor site performance for any additional issues and apologize for any inconvenience that this slowness may have caused.
Posted Aug 15, 2017 - 15:05 UTC
Investigating
A small subset of users are experiencing delays when accessing the site for the first time. After first access, the site performs as normal.
Posted Aug 15, 2017 - 12:52 UTC